aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pcmanfm/pcmanfm_0.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pcmanfm/pcmanfm_0.5.bb')
-rw-r--r--recipes/pcmanfm/pcmanfm_0.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/pcmanfm/pcmanfm_0.5.bb b/recipes/pcmanfm/pcmanfm_0.5.bb
new file mode 100644
index 0000000000..489e95ee72
--- /dev/null
+++ b/recipes/pcmanfm/pcmanfm_0.5.bb
@@ -0,0 +1,26 @@
+LICENSE = "GPL"
+DESCRIPTION = "procfs tools"
+SECTION = "x11"
+PRIORITY = "optional"
+DEPENDS = "gtk+ hal gamin startup-notification"
+RRECOMMENDS = "pmount-hal"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/pcmanfm-${PV}.tar.gz \
+ file://desired_mount_point.patch;patch=1 \
+ file://auto_mount.patch;patch=1 \
+ file://gnome-fs-directory.png \
+ file://gnome-fs-regular.png \
+ file://gnome-mime-text-plain.png \
+ file://emblem-symbolic-link.png \
+ file://desktop.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_install_append () {
+ install -d ${D}/${datadir}
+ install -d ${D}/${datadir}/pixmaps/
+
+ install -m 0644 ${WORKDIR}/*.png ${D}/${datadir}/pixmaps
+}
+
+FILES_${PN} += "${datadir}/pixmaps/*.png"