aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/perl/perl_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/perl/perl_5.8.8.bb')
-rw-r--r--recipes/perl/perl_5.8.8.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes/perl/perl_5.8.8.bb b/recipes/perl/perl_5.8.8.bb
index 8d9719959c..8f6b72b52e 100644
--- a/recipes/perl/perl_5.8.8.bb
+++ b/recipes/perl/perl_5.8.8.bb
@@ -5,7 +5,7 @@ LICENSE = "Artistic|GPL"
PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db perl-native grep-native"
-PR = "r27"
+PR = "r28"
# Major part of version
PVM = "5.8"
@@ -81,6 +81,7 @@ do_configure() {
sed -i -e 's,@DESTDIR@,${D},g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
-e "s%/usr/include/%${STAGING_INCDIR}/%g" \
+ -e 's,/usr/,${layout_exec_prefix}/,g' \
config.sh-${TARGET_ARCH}-${TARGET_OS}
if test "${MACHINE}" != "native"; then
@@ -103,10 +104,9 @@ do_compile() {
oe_runmake perl LD="${TARGET_SYS}-gcc"
}
do_install() {
- oe_runmake install
-
+ oe_runmake install
# Add perl pointing at current version
- ln -sf perl${PV} ${D}/usr/bin/perl
+ ln -sf perl${PV} ${D}${bindir}/perl
# Fix up versioned directories
mv ${D}/${libdir}/perl/${PVM} ${D}/${libdir}/perl/${PV}