aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pmacct/pmacct_0.7.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pmacct/pmacct_0.7.9.bb')
-rw-r--r--recipes/pmacct/pmacct_0.7.9.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/pmacct/pmacct_0.7.9.bb b/recipes/pmacct/pmacct_0.7.9.bb
new file mode 100644
index 0000000000..06cbd9296a
--- /dev/null
+++ b/recipes/pmacct/pmacct_0.7.9.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Promiscuous mode IP Accounting package"
+HOMEPAGE = "http://www.ba.cnr.it/~paolo/pmacct/"
+LICENSE = "GPLv2"
+DEPENDS = "libpcap"
+PR = "r2"
+
+SRC_URI = "http://www.ba.cnr.it/~paolo/pmacct/pmacct-${PV}.tar.gz \
+ file://pmacct.init \
+ file://pmacct.conf.eth0"
+
+inherit autotools
+
+# Without this it'll check for the headers in /usr/include
+EXTRA_OECONF = "--with-pcap-includes=${STAGING_INCDIR}"
+
+do_configure () {
+ oe_runconf
+}
+
+do_install() {
+ autotools_do_install
+ install -d ${D}${sysconfdir}/init.d/
+ install -d ${D}${sysconfdir}/pmacct
+ install -m 755 ${WORKDIR}/pmacct.init ${D}${sysconfdir}/init.d/pmacct
+ install -m 644 ${WORKDIR}/pmacct.conf.eth0 ${D}${sysconfdir}/pmacct
+}
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/pmacct/pmacct.conf.eth0"