aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/portmap/portmap-6.0
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/portmap/portmap-6.0')
-rw-r--r--recipes/portmap/portmap-6.0/destdir-no-strip.patch44
-rw-r--r--recipes/portmap/portmap-6.0/no-libwrap.patch15
-rw-r--r--recipes/portmap/portmap-6.0/no-pie.patch14
-rw-r--r--recipes/portmap/portmap-6.0/no-tcpd-support.patch28
4 files changed, 101 insertions, 0 deletions
diff --git a/recipes/portmap/portmap-6.0/destdir-no-strip.patch b/recipes/portmap/portmap-6.0/destdir-no-strip.patch
new file mode 100644
index 0000000000..a1563c7141
--- /dev/null
+++ b/recipes/portmap/portmap-6.0/destdir-no-strip.patch
@@ -0,0 +1,44 @@
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 13 May 2007 21:15:12 +0000 (-0400)
+Subject: respect DESTDIR and dont use -s with install
+X-Git-Url: http://neil.brown.name/git?p=portmap;a=commitdiff_plain;h=603c59b978c04df2354f68d4a2dc676a758ff46d
+
+respect DESTDIR and dont use -s with install
+
+$(DESTDIR) is the standard for installing into other trees, not $(BASEDIR) ...
+so I've converted the Makefile to use that. I've also left in $(BASEDIR) as a
+default to support old installs; not sure if you'd just cut it.
+
+Stripping should be left to the person to handle, not automatically done by
+the install step. Also, `install -s` always calls `strip` which is
+wrong/undesired in cross-compiling scenarios.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Signed-off-by: Neil Brown <neilb@suse.de>
+---
+
+diff --git a/Makefile b/Makefile
+index 9e9a4b4..5343428 100644
+--- a/Makefile
++++ b/Makefile
+@@ -135,13 +135,14 @@ from_local: CPPFLAGS += -DTEST
+ portmap.man : portmap.8
+ sed $(MAN_SED) < portmap.8 > portmap.man
+
++DESTDIR = $(BASEDIR)
+ install: all
+- install -o root -g root -m 0755 -s portmap ${BASEDIR}/sbin
+- install -o root -g root -m 0755 -s pmap_dump ${BASEDIR}/sbin
+- install -o root -g root -m 0755 -s pmap_set ${BASEDIR}/sbin
+- install -o root -g root -m 0644 portmap.man ${BASEDIR}/usr/share/man/man8/portmap.8
+- install -o root -g root -m 0644 pmap_dump.8 ${BASEDIR}/usr/share/man/man8
+- install -o root -g root -m 0644 pmap_set.8 ${BASEDIR}/usr/share/man/man8
++ install -o root -g root -m 0755 portmap $(DESTDIR)/sbin
++ install -o root -g root -m 0755 pmap_dump $(DESTDIR)/sbin
++ install -o root -g root -m 0755 pmap_set $(DESTDIR)/sbin
++ install -o root -g root -m 0644 portmap.man $(DESTDIR)/usr/share/man/man8/portmap.8
++ install -o root -g root -m 0644 pmap_dump.8 $(DESTDIR)/usr/share/man/man8
++ install -o root -g root -m 0644 pmap_set.8 $(DESTDIR)/usr/share/man/man8
+
+ clean:
+ rm -f *.o portmap pmap_dump pmap_set from_local \
diff --git a/recipes/portmap/portmap-6.0/no-libwrap.patch b/recipes/portmap/portmap-6.0/no-libwrap.patch
new file mode 100644
index 0000000000..a880da6253
--- /dev/null
+++ b/recipes/portmap/portmap-6.0/no-libwrap.patch
@@ -0,0 +1,15 @@
+Index: Makefile
+===================================================================
+--- Makefile.orig 2007-05-15 16:00:17.000000000 +0200
++++ Makefile 2007-05-15 16:00:55.000000000 +0200
+@@ -19,8 +19,8 @@
+ # USE_DNS to add hostname tests in hosts.allow/deny.
+
+ ifeq ($(NO_TCP_WRAPPER),)
+-CPPFLAGS += -DHOSTS_ACCESS
+-WRAP_LIB = -lwrap
++#CPPFLAGS += -DHOSTS_ACCESS
++#WRAP_LIB = -lwrap
+ ifdef USE_DNS
+ CPPFLAGS += -DENABLE_DNS
+ MAN_SED += -e 's/USE_DNS/yes/'
diff --git a/recipes/portmap/portmap-6.0/no-pie.patch b/recipes/portmap/portmap-6.0/no-pie.patch
new file mode 100644
index 0000000000..4d7e2daae4
--- /dev/null
+++ b/recipes/portmap/portmap-6.0/no-pie.patch
@@ -0,0 +1,14 @@
+--- portmap_6.0/Makefile.orig 2007-11-21 00:35:52.000000000 -0600
++++ portmap_6.0/Makefile 2007-11-21 00:37:23.000000000 -0600
+@@ -125,9 +125,9 @@
+ all: portmap pmap_dump pmap_set portmap.man
+
+ CPPFLAGS += $(HOSTS_ACCESS)
+-portmap: CFLAGS += -fpie
++#portmap: CFLAGS += -fpie
+ portmap: LDLIBS += $(WRAP_LIB)
+-portmap: LDFLAGS += -pie
++#portmap: LDFLAGS += -pie
+ portmap: portmap.o pmap_check.o from_local.o
+
+ from_local: CPPFLAGS += -DTEST
diff --git a/recipes/portmap/portmap-6.0/no-tcpd-support.patch b/recipes/portmap/portmap-6.0/no-tcpd-support.patch
new file mode 100644
index 0000000000..da55f3799d
--- /dev/null
+++ b/recipes/portmap/portmap-6.0/no-tcpd-support.patch
@@ -0,0 +1,28 @@
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sun, 13 May 2007 21:17:32 +0000 (-0400)
+Subject: fix building with tcpd support disabled
+X-Git-Url: http://neil.brown.name/git?p=portmap;a=commitdiff_plain;h=7847207aed1b44faf077eed14a9ac9c68244eba5
+
+fix building with tcpd support disabled
+
+Make sure pmap_check.c only includes tcpd.h when HOSTS_ACCESS is defined.
+
+Signed-off-by: Timothy Redaelli <drizzt@gentoo.org>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Signed-off-by: Neil Brown <neilb@suse.de>
+---
+
+diff --git a/pmap_check.c b/pmap_check.c
+index 84f2c12..443a822 100644
+--- a/pmap_check.c
++++ b/pmap_check.c
+@@ -44,7 +44,9 @@
+ #include <netinet/in.h>
+ #include <rpc/rpcent.h>
+ #endif
++#ifdef HOSTS_ACCESS
+ #include <tcpd.h>
++#endif
+ #include <arpa/inet.h>
+ #include <grp.h>
+