aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powernowd
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/powernowd')
-rw-r--r--recipes/powernowd/files/fix-makefile.patch11
-rw-r--r--recipes/powernowd/powernowd_0.96.bb13
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/powernowd/files/fix-makefile.patch b/recipes/powernowd/files/fix-makefile.patch
new file mode 100644
index 0000000000..f17a539744
--- /dev/null
+++ b/recipes/powernowd/files/fix-makefile.patch
@@ -0,0 +1,11 @@
+--- /tmp/Makefile 2005-10-18 19:11:58.513569480 +0200
++++ powernowd-0.96/Makefile 2005-10-18 19:12:37.132698480 +0200
+@@ -4,7 +4,7 @@
+ all: powernow
+
+ powernow:
+- gcc -O2 -Wall -o powernowd powernowd.c
++ ${CC} -O2 -Wall -o powernowd powernowd.c
+
+ install:
+ install -m 755 powernowd /usr/sbin
diff --git a/recipes/powernowd/powernowd_0.96.bb b/recipes/powernowd/powernowd_0.96.bb
new file mode 100644
index 0000000000..9230239bc4
--- /dev/null
+++ b/recipes/powernowd/powernowd_0.96.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "A daemon to manage CPUfreq states"
+HOMEPAGE = "http://www.deater.net/john/powernowd.html"
+LICENSE = "GPLv2"
+
+
+SRC_URI = "http://www.deater.net/john/${P}.tar.gz \
+ file://fix-makefile.patch;patch=1"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -m 755 powernowd ${D}${sbindir}/
+}
+