aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop/powertop.inc
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/powertop/powertop.inc')
-rw-r--r--recipes/powertop/powertop.inc27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/powertop/powertop.inc b/recipes/powertop/powertop.inc
new file mode 100644
index 0000000000..931abadc44
--- /dev/null
+++ b/recipes/powertop/powertop.inc
@@ -0,0 +1,27 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.linuxpowertop.org/"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libintl ncurses"
+
+INC_PR = "r1"
+
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz \
+ file://ldflags.patch;patch=1 \
+ "
+
+CFLAGS = "${LDFLAGS}"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ # sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+ :
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}
+
+
+LDFLAGS_append_linux-uclibc = " -lintl"
+LDFLAGS_append_linux-uclibceabi = " -lintl"
+LDFLAGS_append_linux-uclibcspe = " -lintl"