aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/powertop/powertop_1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/powertop/powertop_1.11.bb')
-rw-r--r--recipes/powertop/powertop_1.11.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/powertop/powertop_1.11.bb b/recipes/powertop/powertop_1.11.bb
new file mode 100644
index 0000000000..2fb8061c59
--- /dev/null
+++ b/recipes/powertop/powertop_1.11.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "PowerTOP, a tool that helps you find what software is using the most power."
+HOMEPAGE = "http://www.linuxpowertop.org/"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libintl ncurses"
+
+SRC_URI = "http://www.lesswatts.org/projects/powertop/download/powertop-${PV}.tar.gz"
+
+SRC_URI_append_beagleboard = " file://omap.patch;patch=1;pnum=0"
+
+CFLAGS += "${LDFLAGS}"
+CFLAGS_beagleboard += "-DOMAP3"
+
+do_configure() {
+ # We do not build ncurses with wide char support
+ sed -i -e "s/lncursesw/lncurses/" ${S}/Makefile
+}
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}