aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/proj4
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/proj4')
-rw-r--r--recipes/proj4/proj-4-native_4.9.bb3
-rw-r--r--recipes/proj4/proj-4.inc18
-rw-r--r--recipes/proj4/proj-4_4.9.bb4
3 files changed, 25 insertions, 0 deletions
diff --git a/recipes/proj4/proj-4-native_4.9.bb b/recipes/proj4/proj-4-native_4.9.bb
new file mode 100644
index 0000000000..e2ce77e4db
--- /dev/null
+++ b/recipes/proj4/proj-4-native_4.9.bb
@@ -0,0 +1,3 @@
+require proj-4.inc
+
+inherit native
diff --git a/recipes/proj4/proj-4.inc b/recipes/proj4/proj-4.inc
new file mode 100644
index 0000000000..da78a384bd
--- /dev/null
+++ b/recipes/proj4/proj-4.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "PROJ.4 - Cartographic Projections Library"
+HOMEPAGE = "http://www.remotesensing.org/proj/"
+LICENSE = "MIT"
+
+PR = "r1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "ftp://ftp.remotesensing.org/proj/proj-4.${PV}.tar.gz"
+
+S = "${WORKDIR}/proj-4.${PV}"
+
+FILES_${PN} += "${datadir}/proj"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/recipes/proj4/proj-4_4.9.bb b/recipes/proj4/proj-4_4.9.bb
new file mode 100644
index 0000000000..d6d4cd9f88
--- /dev/null
+++ b/recipes/proj4/proj-4_4.9.bb
@@ -0,0 +1,4 @@
+require proj-4.inc
+
+DEPENDS += "proj-4-native"
+