aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pth/pth_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pth/pth_2.0.0.bb')
-rw-r--r--recipes/pth/pth_2.0.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/pth/pth_2.0.0.bb b/recipes/pth/pth_2.0.0.bb
new file mode 100644
index 0000000000..8c7f5772a4
--- /dev/null
+++ b/recipes/pth/pth_2.0.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.ossp.org/pkg/lib/pth/pth-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}