summaryrefslogtreecommitdiffstats
path: root/recipes/pth
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pth')
-rw-r--r--recipes/pth/files/m4-warning.patch34
-rw-r--r--recipes/pth/pth_2.0.0.bb27
-rw-r--r--recipes/pth/pth_2.0.2.bb31
3 files changed, 92 insertions, 0 deletions
diff --git a/recipes/pth/files/m4-warning.patch b/recipes/pth/files/m4-warning.patch
new file mode 100644
index 0000000000..6cdc5bbd61
--- /dev/null
+++ b/recipes/pth/files/m4-warning.patch
@@ -0,0 +1,34 @@
+Index: pth-2.0.2/pth.m4
+===================================================================
+--- pth-2.0.2.orig/pth.m4 2004-09-12 13:40:59.000000000 +0200
++++ pth-2.0.2/pth.m4 2008-05-03 16:31:46.000000000 +0200
+@@ -40,7 +40,7 @@
+ dnl ##
+ dnl
+ dnl # auxilliary macros
+-AC_DEFUN(_AC_PTH_ERROR, [dnl
++AC_DEFUN([_AC_PTH_ERROR], [dnl
+ AC_MSG_RESULT([*FAILED*])
+ m4_define(_ac_pth_line,dnl
+ "+------------------------------------------------------------------------+")
+@@ -51,13 +51,13 @@
+ echo " _ac_pth_line" 1>&2
+ exit 1
+ ])
+-AC_DEFUN(_AC_PTH_VERBOSE, [dnl
++AC_DEFUN([_AC_PTH_VERBOSE], [dnl
+ if test ".$verbose" = .yes; then
+ AC_MSG_RESULT([ $1])
+ fi
+ ])
+ dnl # the user macro
+-AC_DEFUN(AC_CHECK_PTH, [dnl
++AC_DEFUN([AC_CHECK_PTH], [dnl
+ dnl
+ dnl # prerequisites
+ AC_REQUIRE([AC_PROG_CC])dnl
+@@ -399,4 +399,3 @@
+ ifelse([$6], , :, [$6])
+ fi
+ ])
+-
diff --git a/recipes/pth/pth_2.0.0.bb b/recipes/pth/pth_2.0.0.bb
new file mode 100644
index 0000000000..8c7f5772a4
--- /dev/null
+++ b/recipes/pth/pth_2.0.0.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.ossp.org/pkg/lib/pth/pth-${PV}.tar.gz"
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}
diff --git a/recipes/pth/pth_2.0.2.bb b/recipes/pth/pth_2.0.2.bb
new file mode 100644
index 0000000000..81b8a71b63
--- /dev/null
+++ b/recipes/pth/pth_2.0.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GNU Portable Threads"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/pth/pth-${PV}.tar.gz \
+ file://m4-warning.patch;patch=1 \
+ "
+
+PARALLEL_MAKE=""
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ oe_libinstall -so libpth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/
+ for X in pth.h
+ do
+ install -m 0644 ${S}/$X ${STAGING_INCDIR}/$X
+ done
+
+ install -d ${STAGING_DATADIR}/aclocal
+ install pth.m4 ${STAGING_DATADIR}/aclocal/
+}