aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/pulseaudio/libcanberra_0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/pulseaudio/libcanberra_0.10.bb')
-rw-r--r--recipes/pulseaudio/libcanberra_0.10.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/pulseaudio/libcanberra_0.10.bb b/recipes/pulseaudio/libcanberra_0.10.bb
new file mode 100644
index 0000000000..c88ad4e731
--- /dev/null
+++ b/recipes/pulseaudio/libcanberra_0.10.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Libcanberra is an implementation of the XDG Sound Theme and Name Specifications, for generating event sounds on free desktops."
+LICENSE = "LGPL"
+DEPENDS = "gtk+ pulseaudio alsa-lib"
+
+inherit gconf autotools
+
+SRC_URI = "http://0pointer.de/lennart/projects/libcanberra/libcanberra-${PV}.tar.gz"
+
+EXTRA_OECONF = " --disable-oss "
+# This needs autoconf 2.62, which isn't used by any distro in OE atm
+do_configure() {
+ gnu-configize --force
+ oe_runconf
+}
+
+FILES_${PN} += "${libdir}/gtk-2.0/modules/ ${datadir}/gnome"
+FILES_${PN}-dbg += "${libdir}/gtk-2.0/modules/.debug"
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+
+