aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/puppy
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/puppy')
-rw-r--r--recipes/puppy/files/usb-header.patch20
-rw-r--r--recipes/puppy/puppy_1.11.bb19
-rw-r--r--recipes/puppy/puppy_1.8.bb16
-rw-r--r--recipes/puppy/puppy_1.9.bb16
4 files changed, 71 insertions, 0 deletions
diff --git a/recipes/puppy/files/usb-header.patch b/recipes/puppy/files/usb-header.patch
new file mode 100644
index 0000000000..3768ff8ff6
--- /dev/null
+++ b/recipes/puppy/files/usb-header.patch
@@ -0,0 +1,20 @@
+--- puppy/usb_io.h.~1.14.~ 2007-02-01 16:39:20.000000000 +1030
++++ puppy/usb_io.h 2007-03-23 11:47:21.000000000 +1030
+@@ -30,12 +30,13 @@
+ #include <linux/types.h>
+ #include <linux/version.h>
+
+-#include <linux/usb.h>
+-#include <linux/usbdevice_fs.h>
+-
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
++/* linux/usb_ch9.h wasn't separated out until 2.4.23 */
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,23)
+ #include "usb_ch9.h"
++#else
++#include "usb.h"
+ #endif
++#include <linux/usbdevice_fs.h>
+
+ #include "mjd.h"
+ #include "tf_bytes.h"
diff --git a/recipes/puppy/puppy_1.11.bb b/recipes/puppy/puppy_1.11.bb
new file mode 100644
index 0000000000..ee9254bd01
--- /dev/null
+++ b/recipes/puppy/puppy_1.11.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Interface software for the TopField TF5000PVRt"
+SECTION = "network"
+PRIORITY = "optional"
+HOMEPAGE = "http://sf.net/projects/puppy/"
+LICENSE = "GPL"
+PR = "r3"
+
+SRC_URI = "cvs://anonymous:@puppy.cvs.sourceforge.net/cvsroot/puppy;module=puppy;tag=PUPPY_1_11 \
+ file://usb-header.patch;patch=1"
+S = "${WORKDIR}/puppy"
+
+inherit autotools
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/puppy ${D}${bindir}/puppy
+}
diff --git a/recipes/puppy/puppy_1.8.bb b/recipes/puppy/puppy_1.8.bb
new file mode 100644
index 0000000000..7696333ca9
--- /dev/null
+++ b/recipes/puppy/puppy_1.8.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Interface software for the TopField TF5000PVRt"
+SECTION = "network"
+PRIORITY = "optional"
+HOMEPAGE = "http://sf.net/projects/puppy/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous:@puppy.cvs.sourceforge.net/cvsroot/puppy;module=puppy;tag=PUPPY_1_8"
+S = "${WORKDIR}/puppy"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/puppy ${D}${bindir}/puppy
+}
diff --git a/recipes/puppy/puppy_1.9.bb b/recipes/puppy/puppy_1.9.bb
new file mode 100644
index 0000000000..6387ee07c7
--- /dev/null
+++ b/recipes/puppy/puppy_1.9.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Interface software for the TopField TF5000PVRt"
+SECTION = "network"
+PRIORITY = "optional"
+HOMEPAGE = "http://sf.net/projects/puppy/"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous:@puppy.cvs.sourceforge.net/cvsroot/puppy;module=puppy;tag=PUPPY_1_9"
+S = "${WORKDIR}/puppy"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/puppy ${D}${bindir}/puppy
+}