aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-egenix-mx-base_3.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-egenix-mx-base_3.1.1.bb')
-rw-r--r--recipes/python/python-egenix-mx-base_3.1.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/python/python-egenix-mx-base_3.1.1.bb b/recipes/python/python-egenix-mx-base_3.1.1.bb
new file mode 100644
index 0000000000..aba3a710c7
--- /dev/null
+++ b/recipes/python/python-egenix-mx-base_3.1.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "The eGenix.com mx Extensions for Python are a collection of professional quality Python software \
+tools which enhance Python's usability in many important areas such as ODBC database connectivity, fast text \
+processing, date/time processing and web site programming."
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "EGENIX"
+SRCNAME = "egenix-mx-base"
+PR = "ml0"
+
+SRC_URI = "http://downloads.egenix.com/python/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+export INCLUDE = "${STAGING_INCDIR}/${PYTHON_DIR}"
+export LIB = "${STAGING_LIBDIR}"
+
+FILES_${PN} += "${datadir}"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/mx/*/*/.debug"