aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-fusil_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-fusil_1.1.bb')
-rw-r--r--recipes/python/python-fusil_1.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/python/python-fusil_1.1.bb b/recipes/python/python-fusil_1.1.bb
new file mode 100644
index 0000000000..f67612eb45
--- /dev/null
+++ b/recipes/python/python-fusil_1.1.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Fusil is a Python library used to write fuzzing programs."
+HOMEPAGE = "http://fusil.hachoir.org/"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+SRCNAME = "fusil"
+PR = "r1"
+
+SRC_URI = "http://pypi.python.org/packages/source/f/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+RDEPENDS_${PN} = "\
+ python-ptrace \
+ python-ctypes \
+ python-lang \
+ python-logging \
+ python-datetime \
+ python-shell \
+ python-resource \
+ python-subprocess \
+"