aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-m2crypto/install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-m2crypto/install.patch')
-rw-r--r--recipes/python/python-m2crypto/install.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/python/python-m2crypto/install.patch b/recipes/python/python-m2crypto/install.patch
new file mode 100644
index 0000000000..6c70ccf516
--- /dev/null
+++ b/recipes/python/python-m2crypto/install.patch
@@ -0,0 +1,24 @@
+Index: m2crypto-0.18.2/setup.py
+===================================================================
+--- m2crypto-0.18.2.orig/setup.py
++++ m2crypto-0.18.2/setup.py
+@@ -38,7 +38,7 @@ class _M2CryptoBuildExt(build_ext.build_
+ self.openssl = 'c:\\pkg'
+ else:
+ self.libraries = ['ssl', 'crypto']
+- self.openssl = '/usr'
++ self.openssl = os.environ.get( "STAGING_DIR" )
+
+
+ def finalize_options(self):
+@@ -47,8 +47,8 @@ class _M2CryptoBuildExt(build_ext.build_
+
+ build_ext.build_ext.finalize_options(self)
+
+- opensslIncludeDir = os.path.join(self.openssl, 'include')
+- opensslLibraryDir = os.path.join(self.openssl, 'lib')
++ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
++ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
+
+ self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
+ [opensslIncludeDir]]