summaryrefslogtreecommitdiffstats
path: root/recipes/python/python-m2crypto_0.20.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-m2crypto_0.20.2.bb')
-rw-r--r--recipes/python/python-m2crypto_0.20.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/python/python-m2crypto_0.20.2.bb b/recipes/python/python-m2crypto_0.20.2.bb
new file mode 100644
index 0000000000..0a9e66e055
--- /dev/null
+++ b/recipes/python/python-m2crypto_0.20.2.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A Python crypto and SSL toolkit"
+SECTION = "devel/python"
+HOMEPAGE = "http://chandlerproject.org/bin/view/Projects/MeTooCrypto"
+PRIORITY = "optional"
+DEPENDS = "openssl swig-native"
+LICENSE = "BSD"
+SRCNAME = "M2Crypto"
+PR = "ml0"
+
+SRC_URI = "\
+ http://pypi.python.org/packages/source/M/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
+ file://install.patch \
+ file://m2crypto-0.20.2-openssl-1.0.0.patch;striplevel=0 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+export STAGING_DIR
+export STAGING_INCDIR
+export STAGING_LIBDIR
+
+SRC_URI[md5sum] = "6c24410410d6eb1920ea43f77a93613a"
+SRC_URI[sha256sum] = "fc66b96ad2a14de1a502358286d3490677eda30385645fca995fffff22b73e6e"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"