aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-ogg_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-ogg_1.3.bb')
-rw-r--r--recipes/python/python-ogg_1.3.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/python/python-ogg_1.3.bb b/recipes/python/python-ogg_1.3.bb
new file mode 100644
index 0000000000..d2d1d9e2ba
--- /dev/null
+++ b/recipes/python/python-ogg_1.3.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Python Ogg Vorbis Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libogg"
+SRCNAME = "pyogg"
+PR = "r1"
+
+SRC_URI = "http://www.andrewchatham.com/pyogg/download/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ touch Setup
+ echo "ogg_libs = ogg" >>Setup
+ echo "ogg_lib_dir = ${STAGING_LIBDIR}" >>Setup
+ echo "ogg_include_dir = ${STAGING_INCDIR}" >>Setup
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/pyogg
+ install -m 0644 include/pyogg/pyogg.h ${STAGING_INCDIR}/pyogg/pyogg.h
+}