aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-opendir/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-opendir/setup.py')
-rw-r--r--recipes/python/python-opendir/setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/python/python-opendir/setup.py b/recipes/python/python-opendir/setup.py
new file mode 100644
index 0000000000..d76b22c95a
--- /dev/null
+++ b/recipes/python/python-opendir/setup.py
@@ -0,0 +1,25 @@
+from distutils.core import setup
+from distutils.extension import Extension
+from Cython.Distutils import build_ext
+
+setup(
+ name = 'opendir',
+ version = '0.0.1',
+ author = 'Gregory Ewing',
+ author_email = 'greg ewing at canterbury ac nz',
+ maintainer = 'Johannes "josch" Schauer',
+ maintainer_email = 'j schauer at email de',
+ description = 'Implements POSIX opendir',
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'Operating System :: POSIX',
+ 'Programming Language :: Pyrex',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: System :: Filesystems'
+ ],
+ ext_modules=[
+ Extension("opendir", ["opendir.pyx"]),
+ ],
+ cmdclass = {'build_ext': build_ext}
+)