aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pycairo_1.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pycairo_1.4.0.bb')
-rw-r--r--recipes/python/python-pycairo_1.4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/python/python-pycairo_1.4.0.bb b/recipes/python/python-pycairo_1.4.0.bb
new file mode 100644
index 0000000000..0cccd76d0f
--- /dev/null
+++ b/recipes/python/python-pycairo_1.4.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Python Bindings for the Cairo canvas library"
+SECTION = "devel/python"
+HOMEPAGE = "http://cairographics.org/pycairo"
+LICENSE = "LGPL MPL"
+DEPENDS = "cairo"
+PR = "ml3"
+
+SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.gz \
+ file://fix-setup-py.patch;patch=1"
+S = "${WORKDIR}/pycairo-${PV}"
+
+inherit distutils pkgconfig
+
+do_configure_append() {
+ sed -e 's:@prefix@:${prefix}:' -e 's:@includedir@:\$\{prefix\}/include:' -e 's:@VERSION@:${PV}:' pycairo.pc.in > pycairo.pc
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}
+ install -m 0644 cairo/pycairo.h ${STAGING_INCDIR}
+}