aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pyiw-0.3.3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pyiw-0.3.3/Makefile')
-rw-r--r--recipes/python/python-pyiw-0.3.3/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/python/python-pyiw-0.3.3/Makefile b/recipes/python/python-pyiw-0.3.3/Makefile
new file mode 100644
index 0000000000..2ea7baec08
--- /dev/null
+++ b/recipes/python/python-pyiw-0.3.3/Makefile
@@ -0,0 +1,18 @@
+# Simple Makfile
+
+NAME = pyiw
+LIBS += -liw
+
+#static: pyiw.c
+# @echo "Statically Building/Linking $(NAME)"
+# @$(CC) $(CFLAGS) -Istaticlibiw $(<) -shared -o $(NAME).so staticlibiw/libiw.a
+
+dynamic: pyiw.c
+ @echo "Dynamically Building/Linking $(NAME)"
+ @$(CC) $(CFLAGS) $(LDFLAGS) $(LIBS) $(<) -shared -o $(NAME).so
+
+clean:
+ @rm -rf *.o
+ @rm -rf $(NAME).so
+ @rm -rf $(NAME).so.t*
+