aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-pylint_0.15.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-pylint_0.15.2.bb')
-rw-r--r--recipes/python/python-pylint_0.15.2.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/python/python-pylint_0.15.2.bb b/recipes/python/python-pylint_0.15.2.bb
new file mode 100644
index 0000000000..d0640607f0
--- /dev/null
+++ b/recipes/python/python-pylint_0.15.2.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Pylint is a python tool that checks if a module satisfy a coding standard. Pylint can be seen as another \
+pychecker since nearly all tests you can do with PyChecker can also be done with Pylint. But Pylint offers some more \
+features, like checking line-code's length, checking if variable names are well-formed according to your coding standard,\
+or checking if declared interfaces are truly implemented, and much more."
+SECTION = "devel/python"
+HOMEPAGE = "http://www.logilab.org/857"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "python-logilab-common"
+SRCNAME = "pylint"
+PR = "ml0"
+
+SRC_URI = "ftp://ftp.logilab.org/pub/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils