aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-setuptools_0.6c9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-setuptools_0.6c9.bb')
-rw-r--r--recipes/python/python-setuptools_0.6c9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/python/python-setuptools_0.6c9.bb b/recipes/python/python-setuptools_0.6c9.bb
new file mode 100644
index 0000000000..179129eb60
--- /dev/null
+++ b/recipes/python/python-setuptools_0.6c9.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
+HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "MIT"
+RDEPENDS = "python-distutils python-compression"
+SRCNAME = "setuptools"
+PR = "ml0"
+
+SRC_URI = "\
+ http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
+ file://fix-log-usage.patch;patch=1 \
+"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_install_prepend() {
+ install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
+}
+
+RDEPENDS = "\
+ python-distutils \
+ python-compression \
+"