aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python/python-vorbis_1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python/python-vorbis_1.4.bb')
-rw-r--r--recipes/python/python-vorbis_1.4.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/python/python-vorbis_1.4.bb b/recipes/python/python-vorbis_1.4.bb
new file mode 100644
index 0000000000..69a341f4f8
--- /dev/null
+++ b/recipes/python/python-vorbis_1.4.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Python Vorbis Bindings"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "libvorbis python-ogg"
+SRCNAME = "pyvorbis"
+PR = "ml0"
+
+SRC_URI = "http://www.andrewchatham.com/pyogg/download/${SRCNAME}-${PV}.tar.gz \
+ file://disable-oggcheck.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+do_configure_prepend() {
+ touch Setup
+ echo "ogg_libs = ogg" >>Setup
+ echo "ogg_lib_dir = ${STAGING_LIBDIR}" >>Setup
+ echo "ogg_include_dir = ${STAGING_INCDIR}" >>Setup
+ echo "vorbis_libs = vorbis vorbisfile vorbisenc" >>Setup
+ echo "vorbis_lib_dir = ${STAGING_LIBDIR}" >>Setup
+ echo "vorbis_include_dir = ${STAGING_INCDIR}" >>Setup
+}