aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/python
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/python')
-rw-r--r--recipes/python/python-twisted_8.2.0.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes/python/python-twisted_8.2.0.bb b/recipes/python/python-twisted_8.2.0.bb
index 7ecbf6c1a1..3f8b657715 100644
--- a/recipes/python/python-twisted_8.2.0.bb
+++ b/recipes/python/python-twisted_8.2.0.bb
@@ -5,7 +5,7 @@ HOMEPAGE = "http://www.twistedmatrix.com"
SECTION = "console/network"
PRIORITY = "optional"
LICENSE = "LGPL"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2 "
S = "${WORKDIR}/Twisted-${PV}"
@@ -43,11 +43,17 @@ RDEPENDS_${PN} += "\
${PN}-words \
"
+do_install_append() {
+ # remove some useless files before packaging
+ find ${D} -name "*.bat" -o -name "*.c" -o -name "*.h" -exec rm {} \;
+}
+
ALLOW_EMPTY = "1"
FILES_${PN} = ""
FILES_${PN}-test = " \
${libdir}/${PYTHON_DIR}/site-packages/twisted/test \
+ ${libdir}/${PYTHON_DIR}/site-packages/twisted/*/test \
"
FILES_${PN}-protocols = " \