aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qclockchange
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qclockchange')
-rw-r--r--recipes/qclockchange/files/qclockchange.desktop6
-rw-r--r--recipes/qclockchange/files/qclockchange.pngbin0 -> 5472 bytes
-rw-r--r--recipes/qclockchange/qclockchange_0.1b.bb24
3 files changed, 30 insertions, 0 deletions
diff --git a/recipes/qclockchange/files/qclockchange.desktop b/recipes/qclockchange/files/qclockchange.desktop
new file mode 100644
index 0000000000..9463623883
--- /dev/null
+++ b/recipes/qclockchange/files/qclockchange.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Comment= Changes the CPU frequency
+Exec=qclockchange
+Icon=qclockchange
+Type=Application
+Name=Qclockchange
diff --git a/recipes/qclockchange/files/qclockchange.png b/recipes/qclockchange/files/qclockchange.png
new file mode 100644
index 0000000000..861fe2eecc
--- /dev/null
+++ b/recipes/qclockchange/files/qclockchange.png
Binary files differ
diff --git a/recipes/qclockchange/qclockchange_0.1b.bb b/recipes/qclockchange/qclockchange_0.1b.bb
new file mode 100644
index 0000000000..7980618f97
--- /dev/null
+++ b/recipes/qclockchange/qclockchange_0.1b.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Program that allows you to set the CCCR registers on PXA Zauruses."
+SECTION = "opie/settings"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "piro <piro400@occn.zaq.ne.jp>"
+HOMEPAGE = "http://piro.sytes.net/~piro/zaurus/"
+APPTYPE="binary"
+PR = "r0"
+
+SRC_URI = "http://piro.sytes.net/~piro/zaurus/etc/qclockchange-${PV}.tar.gz \
+ file://qclockchange.png \
+ file://qclockchange.desktop "
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin/ \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/apps/Settings
+
+ install -m 0755 bin/qclockchange ${D}${palmtopdir}/bin/qclockchange
+ install -m 0644 ${WORKDIR}/qclockchange.png ${D}${palmtopdir}/pics/qclockchange.png
+ install -m 0644 ${WORKDIR}/qclockchange.desktop ${D}${palmtopdir}/apps/Settings/qclockchange.desktop
+}