aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qiv/qiv_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qiv/qiv_1.9.bb')
-rw-r--r--recipes/qiv/qiv_1.9.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/qiv/qiv_1.9.bb b/recipes/qiv/qiv_1.9.bb
new file mode 100644
index 0000000000..17138452a5
--- /dev/null
+++ b/recipes/qiv/qiv_1.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Qiv is a very small and pretty fast gdk/Imlib image viewer."
+LICENSE = "GPLv2"
+SECTION = "x11/graphics"
+DEPENDS = "gtk+-1.2 imlib"
+PR = "r1"
+
+SRC_URI = "http://www.klografx.net/qiv/download/qiv-1.9-src.tgz \
+ file://makefile.patch;patch=1 \
+ "
+inherit pkgconfig binconfig
+
+CFLAGS += " -lSM -lICE -lXdmcp"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1/
+
+ install -s -m 0755 qiv ${D}${bindir}/qiv
+ install -m 0644 qiv.1 ${D}${mandir}/man1/qiv.1
+}