aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qof/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qof/files')
-rw-r--r--recipes/qof/files/fix-includes.patch16
-rw-r--r--recipes/qof/files/libsql-no-host-includes.patch12
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/qof/files/fix-includes.patch b/recipes/qof/files/fix-includes.patch
new file mode 100644
index 0000000000..427a88d0ee
--- /dev/null
+++ b/recipes/qof/files/fix-includes.patch
@@ -0,0 +1,16 @@
+--- /tmp/Makefile.am 2005-11-13 21:41:47.368686720 +0100
++++ qof-0.6.0-pre1/qof/Makefile.am 2005-11-13 21:41:58.637973528 +0100
+@@ -86,13 +86,11 @@
+
+ if USE_LIBGDA
+ INCLUDES = \
+- -I$(includedir) \
+ -DPREFIX=\""$(prefix)"\" \
+ -DDATADIR=\""$(datadir)"\"
+ else
+ INCLUDES = \
+ -I${top_srcdir}/lib/libsql \
+- -I$(includedir) \
+ -DPREFIX=\""$(prefix)"\" \
+ -DDATADIR=\""$(datadir)"\"
+ endif
diff --git a/recipes/qof/files/libsql-no-host-includes.patch b/recipes/qof/files/libsql-no-host-includes.patch
new file mode 100644
index 0000000000..345aa2d4ba
--- /dev/null
+++ b/recipes/qof/files/libsql-no-host-includes.patch
@@ -0,0 +1,12 @@
+--- /tmp/Makefile.am 2006-12-30 13:42:56.000000000 +0100
++++ qof-0.6.0/lib/libsql/Makefile.am 2006-12-30 13:46:03.952227000 +0100
+@@ -30,9 +30,6 @@
+ @CFLAGS@ \
+ @GLIB_CFLAGS@
+
+-INCLUDES = \
+- -I$(includedir)
+-
+ parser.c: parser.y
+ $(YACC) -v -d -o parser.c -p sql parser.y
+