aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qpe-games/aliens-qt_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qpe-games/aliens-qt_1.0.0.bb')
-rw-r--r--recipes/qpe-games/aliens-qt_1.0.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/qpe-games/aliens-qt_1.0.0.bb b/recipes/qpe-games/aliens-qt_1.0.0.bb
new file mode 100644
index 0000000000..77099bfe15
--- /dev/null
+++ b/recipes/qpe-games/aliens-qt_1.0.0.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Alien ShootOut"
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+AUTHOR = "Bill Kendrick"
+HOMEPAGE = "http://www.linux-solutions.at/projects/zaurus/games-Aliens.html"
+
+
+SRC_URI = "http://handhelds.org/~zecke/oe_packages/aliens_V1.0.0.tar.gz \
+ file://Makefile.patch;patch=1 \
+ file://aliens.patch;patch=1"
+
+PV = "1.0.0"
+S = "${WORKDIR}/aliens_V${PV}"
+
+APPNAME = "aliens"
+APPTYPE = "binary"
+APPDESKTOP = "${S}"
+
+do_compile_prepend () {
+ oe_runmake -C images
+}
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${S}/*.png ${D}${palmtopdir}/pics/${APPNAME}/
+
+}
+
+inherit opie
+