aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/qplot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/qplot')
-rw-r--r--recipes/qplot/qplot/gcc3.patch41
-rw-r--r--recipes/qplot/qplot_2.0.1+cvs20020420.bb29
2 files changed, 70 insertions, 0 deletions
diff --git a/recipes/qplot/qplot/gcc3.patch b/recipes/qplot/qplot/gcc3.patch
new file mode 100644
index 0000000000..61f17d9aa3
--- /dev/null
+++ b/recipes/qplot/qplot/gcc3.patch
@@ -0,0 +1,41 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- qplot/qplotmain/calciface.cpp~gcc3 2002-04-18 19:13:29.000000000 +0200
++++ qplot/qplotmain/calciface.cpp 2004-02-19 17:19:37.000000000 +0100
+@@ -38,7 +38,7 @@
+ printf("ibase=%d\n", ibase);
+ }
+ */
+-void sendSpecialVarDecCommand(const char *var, int scale, bool return_to_prev_ibase=true) {
++void sendSpecialVarDecCommand(const char *var, int scale, bool return_to_prev_ibase) {
+ printf("ibase_save=ibase\nibase=ibase_decimal\n");
+ printf("%s=%d\n", var, scale);
+ if( return_to_prev_ibase ) {
+@@ -78,4 +78,4 @@
+ "\n");
+ while ( receiveResult() == NULL )
+ usleep(50);
+-}
+\ Kein Zeilenumbruch am Dateiende.
++}
+--- qplot/qplotmain/calciface.h~gcc3 2002-04-18 19:13:08.000000000 +0200
++++ qplot/qplotmain/calciface.h 2004-02-19 17:21:38.000000000 +0100
+@@ -18,6 +18,9 @@
+ #include <unistd.h>
+ #include <string.h>
+
++#ifndef CALCIFACE_H
++#define CALCIFACE_H
++
+ void resetEngineState ( );
+ void saveIBaseDecimal ( );
+ void saveScaleWorkaround ( bool save);
+@@ -29,3 +32,5 @@
+
+ char * receiveResult ( );
+
++#endif
++
diff --git a/recipes/qplot/qplot_2.0.1+cvs20020420.bb b/recipes/qplot/qplot_2.0.1+cvs20020420.bb
new file mode 100644
index 0000000000..515eefaafc
--- /dev/null
+++ b/recipes/qplot/qplot_2.0.1+cvs20020420.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "QPlot is an Advanced Matematical Calculator for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://qplot.sourceforge.net/"
+SRCDATE = "20020420"
+#Change to form x.y.z+cvs${SRCDATE} when 2.0.1 changes in PV
+PV = "2.0.1-cvs-${SRCDATE}"
+PR = "r1"
+
+SRC_URI = "cvs://anonymous@qplot.cvs.sourceforge.net/cvsroot/qplot;module=qplot \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/qplot"
+
+inherit palmtop
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/apps/Applications \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/lib \
+ ${D}${palmtopdir}/plugins/inputmethods
+ install -m 755 qplotmain/qplot ${D}${palmtopdir}/bin/qplot
+ install -m 644 qplotmain/qplot.png ${D}${palmtopdir}/pics/
+ install -m 644 qplotmain/qplot-const.b ${D}${palmtopdir}/lib/
+ install -m 644 qplotmain/qplot-math.b ${D}${palmtopdir}/lib/
+ oe_libinstall -so -C qplotmath libqplotmath ${D}${palmtopdir}/plugins/inputmethods/
+ install -m 644 qplot.desktop ${D}${palmtopdir}/apps/Applications/qplot.desktop
+}