summaryrefslogtreecommitdiffstats
path: root/recipes/rdesktop/rdesktop_1.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rdesktop/rdesktop_1.3.1.bb')
-rw-r--r--recipes/rdesktop/rdesktop_1.3.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/rdesktop/rdesktop_1.3.1.bb b/recipes/rdesktop/rdesktop_1.3.1.bb
new file mode 100644
index 0000000000..d50a0c1e8c
--- /dev/null
+++ b/recipes/rdesktop/rdesktop_1.3.1.bb
@@ -0,0 +1,27 @@
+require rdesktop.inc
+
+SRC_URI +="file://configure.patch;patch=1"
+
+# Note - rdesktop 1.3.1 doesn't use autotools - don't make the same
+# mistakes I did.. :)
+
+do_configure() {
+ ${S}/configure \
+ --prefix=${prefix} \
+ --exec-prefix=${exec_prefix} \
+ --bindir=${bindir} \
+ --mandir=${mandir} \
+ --sharedir=${datadir} \
+ --with-x=${STAGING_EXECPREFIXDIR} \
+ --with-openssl=${STAGING_EXECPREFIXDIR} \
+ --with-oss \
+ --without-debug
+}
+
+do_compile() {
+ oe_runmake 'KEYMAP_PATH=${datadir}/keymaps/'
+}
+
+do_install() {
+ oe_runmake DESTDIR=${D} install
+}