aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/recode/recode_3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/recode/recode_3.6.bb')
-rw-r--r--recipes/recode/recode_3.6.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/recode/recode_3.6.bb b/recipes/recode/recode_3.6.bb
new file mode 100644
index 0000000000..6fd60ae399
--- /dev/null
+++ b/recipes/recode/recode_3.6.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Charset converting utility"
+SECTION = "console/utils"
+LICENSE = "GPL"
+
+PR = "r1"
+SRC_URI = "${GNU_MIRROR}/recode/recode-${PV}.tar.gz"
+FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/recode-${PV}', '${FILE_DIRNAME}' ], d)}"
+
+SRC_URI += "file://recode-bitfield-width.patch;patch=1 \
+ "
+
+inherit autotools
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+ echo "#undef malloc" >>config.h
+ echo "#undef realloc" >>config.h
+}
+
+do_stage() {
+ install -m 0644 src/recode.h ${STAGING_INCDIR}/
+ install -m 0644 src/recodext.h ${STAGING_INCDIR}/
+ oe_libinstall -a -C src librecode ${STAGING_LIBDIR}/
+}
+