summaryrefslogtreecommitdiffstats
path: root/recipes/redboot-utils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/redboot-utils')
-rw-r--r--recipes/redboot-utils/fconfig_20060419.bb14
-rw-r--r--recipes/redboot-utils/fis_1.0.bb14
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes/redboot-utils/fconfig_20060419.bb b/recipes/redboot-utils/fconfig_20060419.bb
new file mode 100644
index 0000000000..561718f9b2
--- /dev/null
+++ b/recipes/redboot-utils/fconfig_20060419.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Tool to edit the Redboot config from userspace"
+PR = "r1"
+
+SRC_URI = "http://andrzejekiert.ovh.org/software/fconfig/fconfig-20060419.tar.gz"
+
+S = ${WORKDIR}/fconfig
+do_compile() {
+ ${MAKE}
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/fconfig ${D}/${sbindir}
+}
diff --git a/recipes/redboot-utils/fis_1.0.bb b/recipes/redboot-utils/fis_1.0.bb
new file mode 100644
index 0000000000..e1ac56448b
--- /dev/null
+++ b/recipes/redboot-utils/fis_1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Tool to edit the Redboot FIS partition layout from userspace"
+PR = "r5"
+
+SRC_URI = "svn://svn.nslu2-linux.org/svnroot/fis;module=trunk;proto=http;rev=6"
+S="${WORKDIR}/trunk"
+
+export CFLAGS += "--std=c99"
+
+do_install() {
+ ${STRIP} ${S}/fis
+
+ install -d ${D}/${sbindir}
+ install -m 755 ${S}/fis ${D}/${sbindir}
+}