aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/regina-rexx/regina-rexx_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/regina-rexx/regina-rexx_3.3.bb')
-rw-r--r--recipes/regina-rexx/regina-rexx_3.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/regina-rexx/regina-rexx_3.3.bb b/recipes/regina-rexx/regina-rexx_3.3.bb
new file mode 100644
index 0000000000..8634c7f89b
--- /dev/null
+++ b/recipes/regina-rexx/regina-rexx_3.3.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A cross-platform REXX interpreter"
+SECTION = "devel/rexx"
+LICENSE = "GPL"
+HOMEPAGE = "http://regina-rexx.sf.net"
+DEPENDS = "regina-rexx-native"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/regina-rexx/regina33.zip \
+ file://use-proper-host-tools.patch;patch=1"
+S = "${WORKDIR}"
+
+inherit autotools
+
+PARALLEL_MAKE = ""
+
+# need to use configure script built by ancient autotools
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}"
+}
+
+do_install() {
+ oe_runmake install bindir="${D}${bindir}" libdir="${D}${libdir}" includedir="${D}${includedir}" \
+ sharedir="${D}${datadir}" mandir="${D}${mandir}" sysconfdir="${D}${sysconfdir}" \
+ STAGING_BINDIR_NATIVE="${STAGING_BINDIR_NATIVE}"
+}
+
+FILES_${PN} += "${datadir}"
+