aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rfakeap
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rfakeap')
-rw-r--r--recipes/rfakeap/rfakeap_0.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/rfakeap/rfakeap_0.2.bb b/recipes/rfakeap/rfakeap_0.2.bb
new file mode 100644
index 0000000000..036831a11e
--- /dev/null
+++ b/recipes/rfakeap/rfakeap_0.2.bb
@@ -0,0 +1,22 @@
+SECTION = "console/network"
+DESCRIPTION = "Raw Fake AP"
+HOMEPAGE = "http://rfakeap.tuxfamily.org/"
+LICENSE = "GPLv2"
+DEPENDS = "libpcap"
+PV="0.2"
+PR ="r1"
+
+SRC_URI = "http://rfakeap.tuxfamily.org/rfakeap-0.2.tar.gz"
+
+#EXTRA_OEMAKE = "CFLAGS='${CFLAGS} -O3'"
+
+oe_compile() {
+ oe_runmake CC="${CC}" CXX="${CXX}" CFLAGS="-O3 ${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}"
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -d ${D}/${sysconfdir}
+ install -m 0755 ${WORKDIR}/${PN}-${PV}/rfakeap ${D}/${sbindir}
+# install -m 0644 ap_manuf ${D}/${sysconfdir}
+}