aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rt-tests
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rt-tests')
-rw-r--r--recipes/rt-tests/rt-tests_0.28.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/rt-tests/rt-tests_0.28.bb b/recipes/rt-tests/rt-tests_0.28.bb
new file mode 100644
index 0000000000..4c278ccd2d
--- /dev/null
+++ b/recipes/rt-tests/rt-tests_0.28.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Real-time tests, such as cyclictest, for real-time linux PREEMPT RT kernels"
+HOMEPAGE = "http://rt.wiki.kernel.org/index.php/Cyclictest"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/kernel/people/tglx/rt-tests/rt-tests-${PV}.tar.bz2"
+
+S = "${WORKDIR}/rt-tests"
+
+# Limit to cyclictest only for non-real-time kernels.
+# EXTRA_OEMAKE = "cyclictest"
+
+do_install() {
+ install -d ${D}${bindir}
+ # any file that is executable by user and/or group
+ for binary in `find . -perm /u+x,g+x -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
+}