aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rt2x00/rt2570-k2wrlz_1.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rt2x00/rt2570-k2wrlz_1.6.0.bb')
-rw-r--r--recipes/rt2x00/rt2570-k2wrlz_1.6.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/rt2x00/rt2570-k2wrlz_1.6.0.bb b/recipes/rt2x00/rt2570-k2wrlz_1.6.0.bb
new file mode 100644
index 0000000000..32d17f3e56
--- /dev/null
+++ b/recipes/rt2x00/rt2570-k2wrlz_1.6.0.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Driver for Ralink rt2570 USB 802.11g WiFi sticks"
+HOMEPAGE = "http://rt2x00.serialmonkey.com/"
+SECTION = "kernel/modules"
+LICENSE = "GPL"
+
+PR = "r1"
+
+SRC_URI = "http://homepages.tu-darmstadt.de/~p_larbig/wlan/${PN}-${PV}.tar.bz2"
+
+inherit module
+
+S = "${WORKDIR}/${PN}-${PV}/Module/"
+
+EXTRA_OEMAKE = "KERNDIR=${STAGING_KERNEL_DIR}"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 rt2570${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}