aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/rtaudio/rtaudio-tests_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/rtaudio/rtaudio-tests_3.0.1.bb')
-rw-r--r--recipes/rtaudio/rtaudio-tests_3.0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/rtaudio/rtaudio-tests_3.0.1.bb b/recipes/rtaudio/rtaudio-tests_3.0.1.bb
new file mode 100644
index 0000000000..991f55d574
--- /dev/null
+++ b/recipes/rtaudio/rtaudio-tests_3.0.1.bb
@@ -0,0 +1,26 @@
+require librtaudio_${PV}.bb
+
+inherit autotools
+
+EXTRA_OECONF = "--with-alsa --with-oss"
+EXTRA_OEMAKE = "-e"
+export CC = "${CXX}"
+CFLAGS += "-I${S}"
+export LIBRARY = "-lasound -lpthread ${LDFLAGS}"
+
+do_compile() {
+ oe_runmake -C tests
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ for binary in `find tests -perm 0755 -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
+}
+