aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sablevm/sablevm-classpath_1.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sablevm/sablevm-classpath_1.11.3.bb')
-rw-r--r--recipes/sablevm/sablevm-classpath_1.11.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/sablevm/sablevm-classpath_1.11.3.bb b/recipes/sablevm/sablevm-classpath_1.11.3.bb
new file mode 100644
index 0000000000..0546dcacd6
--- /dev/null
+++ b/recipes/sablevm/sablevm-classpath_1.11.3.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "GNU Classpath modified to work with SableVM"
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "Classpath"
+PRIORITY = "optional"
+SECTION = "libs"
+
+DEPENDS = "glib-2.0 gtk+ libart-lgpl pango libxtst virtual/javac-native zip-native"
+RDEPENDS_${PN} = "${PN}-native (>= ${PV})"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz \
+ file://disable-automake-checks.patch;patch=1"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-compressed-classes=zip"
+
+PACKAGES += " ${PN}-native"
+
+FILES_${PN} = "${datadir}/${PN} \
+ ${libdir}/sablevm"
+FILES_${PN}-native = "${libdir}/${PN}"
+
+do_install() {
+ autotools_do_install
+ mv ${D}${libdir}/security ${D}${libdir}/${PN}
+}