aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sablevm/sablevm_1.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sablevm/sablevm_1.11.3.bb')
-rw-r--r--recipes/sablevm/sablevm_1.11.3.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/sablevm/sablevm_1.11.3.bb b/recipes/sablevm/sablevm_1.11.3.bb
new file mode 100644
index 0000000000..154745dfeb
--- /dev/null
+++ b/recipes/sablevm/sablevm_1.11.3.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "A highly-portable Java virtual machine implementing the Java virtual machine specification, second edition."
+HOMEPAGE = "http://sablevm.org"
+LICENSE = "LGPL"
+PRIORITY = "optional"
+SECTION = "interpreters"
+
+DEPENDS = "libffi libtool popt \
+ sablevm-classpath"
+# unzip"
+RRECOMMENDS = "sablevm-classpath (>= ${PV})"
+
+SRC_URI = "http://sablevm.org/download/release/${PV}/${PN}-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+EXTRA_OECONF = "--enable-real-life-brokenness \
+ --disable-errors-on-warnings --disable-signals-for-exceptions"
+
+PROVIDES = "virtual/java"
+ALTERNATIVE_NAME = "java"
+ALTERNATIVE_PATH = "${bindir}/java-sablevm"
+ALTERNATIVE_PRIORITY = "350"
+
+PACKAGES = "${PN}-dbg ${PN} ${PN}-doc lib${PN} lib${PN}-dev"
+
+FILES_${PN} = "${bindir} \
+ ${libdir}/${PN}/bin"
+
+FILES_lib${PN} = "${libdir}/lib${PN}-*.so"
+
+FILES_lib${PN}-dev = "${includedir}/jni* \
+ ${libdir}/lib${PN}.so \
+ ${libdir}/lib${PN}.la"
+
+do_install_append() {
+ install -d ${D}${docdir}
+ mv ${D}${datadir}/${PN} ${D}${docdir}/
+
+ # symlink only present in the deb...
+ install -d ${D}${libdir}/${PN}/bin
+ cd ${D}${libdir}/${PN}/bin && ln -sf ../../../bin/java-sablevm java
+}