aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/samba/samba-3.0.34/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/samba/samba-3.0.34/configure.patch')
-rw-r--r--recipes/samba/samba-3.0.34/configure.patch213
1 files changed, 213 insertions, 0 deletions
diff --git a/recipes/samba/samba-3.0.34/configure.patch b/recipes/samba/samba-3.0.34/configure.patch
new file mode 100644
index 0000000000..ddcb9e9a15
--- /dev/null
+++ b/recipes/samba/samba-3.0.34/configure.patch
@@ -0,0 +1,213 @@
+diff -urN source.old//aclocal.m4 source//aclocal.m4
+--- source.old//aclocal.m4 2008-08-25 22:09:21.000000000 +0100
++++ source//aclocal.m4 2008-11-23 17:44:58.050646210 +0000
+@@ -1,5 +1,5 @@
+ dnl test whether dirent has a d_off member
+-AC_DEFUN(AC_DIRENT_D_OFF,
++AC_DEFUN([AC_DIRENT_D_OFF],
+ [AC_CACHE_CHECK([for d_off in dirent], ac_cv_dirent_d_off,
+ [AC_TRY_COMPILE([
+ #include <unistd.h>
+@@ -13,7 +13,7 @@
+
+ dnl Mark specified module as shared
+ dnl SMB_MODULE(name,static_files,shared_files,subsystem,whatif-static,whatif-shared)
+-AC_DEFUN(SMB_MODULE,
++AC_DEFUN([SMB_MODULE],
+ [
+ AC_MSG_CHECKING([how to build $1])
+ if test "$[MODULE_][$1]"; then
+@@ -44,7 +44,7 @@
+ fi
+ ])
+
+-AC_DEFUN(SMB_SUBSYSTEM,
++AC_DEFUN([SMB_SUBSYSTEM],
+ [
+ AC_SUBST($1_STATIC)
+ AC_SUBST($1_MODULES)
+@@ -229,7 +229,7 @@
+
+ dnl Define an AC_DEFINE with ifndef guard.
+ dnl AC_N_DEFINE(VARIABLE [, VALUE])
+-define(AC_N_DEFINE,
++define([AC_N_DEFINE],
+ [cat >> confdefs.h <<\EOF
+ [#ifndef] $1
+ [#define] $1 ifelse($#, 2, [$2], $#, 3, [$2], 1)
+@@ -239,14 +239,14 @@
+
+ dnl Add an #include
+ dnl AC_ADD_INCLUDE(VARIABLE)
+-define(AC_ADD_INCLUDE,
++define([AC_ADD_INCLUDE],
+ [cat >> confdefs.h <<\EOF
+ [#include] $1
+ EOF
+ ])
+
+ dnl Copied from libtool.m4
+-AC_DEFUN(AC_PROG_LD_GNU,
++AC_DEFUN([AC_PROG_LD_GNU],
+ [AC_CACHE_CHECK([if the linker ($LD) is GNU ld], ac_cv_prog_gnu_ld,
+ [# I'd rather use --version here, but apparently some GNU ld's only accept -v.
+ if $LD -v 2>&1 </dev/null | egrep '(GNU|with BFD)' 1>&5; then
+@@ -257,7 +257,7 @@
+ ])
+
+ dnl Removes -I/usr/include/? from given variable
+-AC_DEFUN(CFLAGS_REMOVE_USR_INCLUDE,[
++AC_DEFUN([CFLAGS_REMOVE_USR_INCLUDE],[
+ ac_new_flags=""
+ for i in [$]$1; do
+ case [$]i in
+@@ -270,7 +270,7 @@
+
+ dnl Removes '-L/usr/lib[/]', '-Wl,-rpath,/usr/lib[/]'
+ dnl and '-Wl,-rpath -Wl,/usr/lib[/]' from given variable
+-AC_DEFUN(LIB_REMOVE_USR_LIB,[
++AC_DEFUN([LIB_REMOVE_USR_LIB],[
+ ac_new_flags=""
+ l=""
+ for i in [$]$1; do
+@@ -301,7 +301,7 @@
+
+ dnl From Bruno Haible.
+
+-AC_DEFUN(jm_ICONV,
++AC_DEFUN([jm_ICONV],
+ [
+ dnl Some systems have iconv in libc, some have it in libiconv (OSF/1 and
+ dnl those with the standalone portable libiconv installed).
+@@ -387,7 +387,7 @@
+ fi
+ ])
+
+-AC_DEFUN(rjs_CHARSET,[
++AC_DEFUN([rjs_CHARSET],[
+ dnl Find out if we can convert from $1 to UCS2-LE
+ AC_MSG_CHECKING([can we convert from $1 to UCS2-LE?])
+ AC_TRY_RUN([
+@@ -405,7 +405,7 @@
+
+ dnl CFLAGS_ADD_DIR(CFLAGS, $INCDIR)
+ dnl This function doesn't add -I/usr/include into CFLAGS
+-AC_DEFUN(CFLAGS_ADD_DIR,[
++AC_DEFUN([CFLAGS_ADD_DIR],[
+ if test "$2" != "/usr/include" ; then
+ $1="$$1 -I$2"
+ fi
+@@ -413,7 +413,7 @@
+
+ dnl LIB_ADD_DIR(LDFLAGS, $LIBDIR)
+ dnl This function doesn't add -L/usr/lib into LDFLAGS
+-AC_DEFUN(LIB_ADD_DIR,[
++AC_DEFUN([LIB_ADD_DIR],[
+ if test "$2" != "/usr/lib" ; then
+ $1="$$1 -L$2"
+ fi
+@@ -486,7 +486,7 @@
+ dnl AC_TRY_RUN_STRICT(PROGRAM,CFLAGS,CPPFLAGS,LDFLAGS,
+ dnl [ACTION-IF-TRUE],[ACTION-IF-FALSE],
+ dnl [ACTION-IF-CROSS-COMPILING = RUNTIME-ERROR])
+-AC_DEFUN( [AC_TRY_RUN_STRICT],
++AC_DEFUN([AC_TRY_RUN_STRICT],
+ [
+ old_CFLAGS="$CFLAGS";
+ CFLAGS="$2";
+diff -urN source.old//configure.in source//configure.in
+--- source.old//configure.in 2008-08-25 22:09:21.000000000 +0100
++++ source//configure.in 2008-11-23 17:22:17.108791515 +0000
+@@ -1402,7 +1402,7 @@
+ #endif
+ exit(0);
+ }
+-], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
++], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no], [linux_getgrouplist_ok=cross])
+ if test x"$linux_getgrouplist_ok" = x"yes"; then
+ AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
+ fi
+diff -urN source.old//lib/replace/libreplace.m4 source//lib/replace/libreplace.m4
+--- source.old//lib/replace/libreplace.m4 2008-08-25 22:09:21.000000000 +0100
++++ source//lib/replace/libreplace.m4 2008-11-23 17:54:27.942153096 +0000
+@@ -1,4 +1,4 @@
+-AC_DEFUN_ONCE(AC_LIBREPLACE_LOCATION_CHECKS,
++AC_DEFUN_ONCE([AC_LIBREPLACE_LOCATION_CHECKS],
+ [
+ echo "LIBREPLACE_LOCATION_CHECKS: START"
+
+@@ -27,7 +27,7 @@
+ ]) dnl end AC_LIBREPLACE_LOCATION_CHECKS
+
+
+-AC_DEFUN_ONCE(AC_LIBREPLACE_BROKEN_CHECKS,
++AC_DEFUN_ONCE([AC_LIBREPLACE_BROKEN_CHECKS],
+ [
+ echo "LIBREPLACE_BROKEN_CHECKS: START"
+
+@@ -325,25 +325,25 @@
+ AC_DEFINE(HAVE_VOLATILE, 1, [Whether the C compiler understands volatile])
+ fi
+
+-m4_include(system/config.m4)
++m4_include(lib/replace/system/config.m4)
+
+-m4_include(dlfcn.m4)
+-m4_include(getpass.m4)
+-m4_include(strptime.m4)
+-m4_include(win32.m4)
+-m4_include(timegm.m4)
+-m4_include(repdir.m4)
++m4_include(lib/replace/dlfcn.m4)
++m4_include(lib/replace/getpass.m4)
++m4_include(lib/replace/strptime.m4)
++m4_include(lib/replace/win32.m4)
++m4_include(lib/replace/timegm.m4)
++m4_include(lib/replace/repdir.m4)
+
+ AC_CHECK_FUNCS([syslog memset memcpy],,[AC_MSG_ERROR([Required function not found])])
+
+ echo "LIBREPLACE_BROKEN_CHECKS: END"
+ ]) dnl end AC_LIBREPLACE_BROKEN_CHECKS
+
+-AC_DEFUN_ONCE(AC__LIBREPLACE_ALL_CHECKS_START,
++AC_DEFUN_ONCE([AC__LIBREPLACE_ALL_CHECKS_START],
+ [
+ #LIBREPLACE_ALL_CHECKS: START"
+ ])
+-AC_DEFUN_ONCE(AC__LIBREPLACE_ALL_CHECKS_END,
++AC_DEFUN_ONCE([AC__LIBREPLACE_ALL_CHECKS_END],
+ [
+ #LIBREPLACE_ALL_CHECKS: END"
+ ])
+@@ -356,6 +356,6 @@
+ AC__LIBREPLACE_ALL_CHECKS_END
+ ])
+
+-m4_include(libreplace_cc.m4)
+-m4_include(libreplace_macros.m4)
+-m4_include(autoconf-2.60.m4)
++m4_include(lib/replace/libreplace_cc.m4)
++m4_include(lib/replace/libreplace_macros.m4)
++m4_include(lib/replace/autoconf-2.60.m4)
+diff -urN source.old//lib/replace/libreplace_macros.m4 source//lib/replace/libreplace_macros.m4
+--- source.old//lib/replace/libreplace_macros.m4 2008-08-25 22:09:21.000000000 +0100
++++ source//lib/replace/libreplace_macros.m4 2008-11-23 17:31:08.269791372 +0000
+@@ -76,7 +76,7 @@
+ ])
+
+ dnl AC_PROG_CC_FLAG(flag)
+-AC_DEFUN(AC_PROG_CC_FLAG,
++AC_DEFUN([AC_PROG_CC_FLAG],
+ [AC_CACHE_CHECK(whether ${CC-cc} accepts -$1, ac_cv_prog_cc_$1,
+ [echo 'void f(){}' > conftest.c
+ if test -z "`${CC-cc} -$1 -c conftest.c 2>&1`"; then
+@@ -103,7 +103,7 @@
+ dnl see if a declaration exists for a function or variable
+ dnl defines HAVE_function_DECL if it exists
+ dnl AC_HAVE_DECL(var, includes)
+-AC_DEFUN(AC_HAVE_DECL,
++AC_DEFUN([AC_HAVE_DECL],
+ [
+ AC_CACHE_CHECK([for $1 declaration],ac_cv_have_$1_decl,[
+ AC_TRY_COMPILE([$2],[int i = (int)$1],