summaryrefslogtreecommitdiffstats
path: root/recipes/samba/samba_3.3.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/samba/samba_3.3.9.bb')
-rw-r--r--recipes/samba/samba_3.3.9.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/samba/samba_3.3.9.bb b/recipes/samba/samba_3.3.9.bb
new file mode 100644
index 0000000000..87a7c5e7f7
--- /dev/null
+++ b/recipes/samba/samba_3.3.9.bb
@@ -0,0 +1,35 @@
+require samba.inc
+require samba-basic.inc
+LICENSE = "GPLv3"
+
+# 3.3.0 and newer will upgrade your tdb database to a
+# new version that you can not downgrade to use with older
+# releases. More testing will happen before this is removed
+# should there be further issues. Appears to work though :)
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://configure-3.3.0.patch;patch=1 \
+ file://config-h.patch;patch=1 \
+ file://mtab.patch;patch=1 \
+ file://tdbheaderfix.patch;patch=1 "
+
+PR = "r3"
+
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+ linux_getgrouplist_ok=no \
+ samba_cv_HAVE_BROKEN_GETGROUPS=no \
+ samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+ samba_cv_have_setresuid=yes \
+ samba_cv_have_setresgid=yes \
+ samba_cv_HAVE_WRFILE_KEYTAB=yes \
+ "
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile () {
+ base_do_compile
+}