aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sbagen
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sbagen')
-rw-r--r--recipes/sbagen/sbagen_1.4.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/sbagen/sbagen_1.4.1.bb b/recipes/sbagen/sbagen_1.4.1.bb
new file mode 100644
index 0000000000..41918485ed
--- /dev/null
+++ b/recipes/sbagen/sbagen_1.4.1.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Binaural tone generation tool."
+HOMEPAGE = "http://uazu.net/sbagen/"
+LICENSE = "GPL"
+DEPENDS = "tremor"
+
+SRC_URI = "http://uazu.net/sbagen/sbagen-${PV}.tgz"
+S = "${WORKDIR}/sbagen-${PV}"
+
+LIBS = "-lm -lpthread -lvorbisidec"
+DEFS = "-DT_LINUX -DOGG_DECODE"
+# LIBS = "-lm -lpthread -lmad"
+# DEFS = "-DT_LINUX -DMP3_DECODE"
+
+do_compile () {
+ ${CC} ${CFLAGS} ${DEFS} sbagen.c ${LDFLAGS} -o sbagen ${LIBS}
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 sbagen ${D}${bindir}/
+}