summaryrefslogtreecommitdiffstats
path: root/recipes/sdlperl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sdlperl')
-rw-r--r--recipes/sdlperl/Makefile.patch17
-rw-r--r--recipes/sdlperl/sdl-perl_1.20.3.bb18
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes/sdlperl/Makefile.patch b/recipes/sdlperl/Makefile.patch
new file mode 100644
index 0000000000..ae20c08c77
--- /dev/null
+++ b/recipes/sdlperl/Makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.linux.orig 2004-06-25 12:44:53.000000000 +0100
++++ Makefile.linux 2004-06-25 12:45:37.000000000 +0100
+@@ -119,12 +119,12 @@
+ my %options = (
+ 'NAME' => 'SDL_perl',
+ 'VERSION_FROM' => 'lib/SDL.pm',
+- 'LIBS' => [ join( " ", "$sdl_libs",
++ 'LIBS' => [ join( " ", $ENV{"LDFLAGS"}, "$sdl_libs",
+ map { $ext{$_}{exists} ? "-l$_" : '' } (sort keys %ext),
+ )
+ ],
+ 'DEFINE' => join ( " ", @defs, map { $ext{$_}{exists} ? "-D$ext{$_}{inc}" : '' } sort keys %ext),
+- 'INC' => "$inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
++ 'INC' => $ENV{"CFLAGS"} . " $inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
+ 'OBJECT' => (
+ ($ext{SDL_image}{exists} ? 'SFont.o ' : "") .
+ 'SDL_perl.o ' .
diff --git a/recipes/sdlperl/sdl-perl_1.20.3.bb b/recipes/sdlperl/sdl-perl_1.20.3.bb
new file mode 100644
index 0000000000..6820fa05ce
--- /dev/null
+++ b/recipes/sdlperl/sdl-perl_1.20.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Perl bindings for SDL"
+SECTION = "libs"
+HOMEPAGE = "http://sdl.perl.org/"
+LICENSE = "GPL"
+DEPENDS = "perl virtual/libsdl libsdl-image libsdl-gfx libsdl-ttf libsdl-mixer libsdl-net smpeg"
+PR = "r1"
+
+SRC_URI = "http://bloodgate.com/perl/sdl/pub/SDL_perl-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_perl-${PV}"
+
+inherit cpan
+
+do_configure_prepend() {
+ # Search staging area for includes
+ sed -i -e 's:/usr/\(local/\)\{0,1\}include:${STAGING_INCDIR}:g' Makefile.linux
+ # smpeg.h isn't in a subdirectry
+ sed -i -e 's:#include <smpeg/smpeg.h>:#include <smpeg.h>:g' SDL_perl.xs
+}