aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/serial-utils
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/serial-utils')
-rw-r--r--recipes/serial-utils/pty-forward-native.bb27
-rw-r--r--recipes/serial-utils/serial-forward.bb19
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes/serial-utils/pty-forward-native.bb b/recipes/serial-utils/pty-forward-native.bb
new file mode 100644
index 0000000000..54ff591928
--- /dev/null
+++ b/recipes/serial-utils/pty-forward-native.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Receive a forwarded serial from serial-forward and provide a PTY"
+AUTHOR = "Holger 'Zecke' Freyther"
+LICENSE = "GPL"
+SECTION = "console/network"
+PV = "1.0.0+svnr${SRCREV}""
+PR = "r0"
+
+SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S = "${WORKDIR}/serial_forward"
+
+inherit native
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+}
+
+addtask deploy before do_package after do_install
diff --git a/recipes/serial-utils/serial-forward.bb b/recipes/serial-utils/serial-forward.bb
new file mode 100644
index 0000000000..c3b879a0ee
--- /dev/null
+++ b/recipes/serial-utils/serial-forward.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Forward a serial using TCP/IP"
+AUTHOR = "Holger 'Zecke' Freyther'"
+LICENSE = "GPL"
+SECTION = "console/devel"
+PV = "1.0.0+svnr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S = "${WORKDIR}/serial_forward"
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
+}