aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/libphone-ui_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr/libphone-ui_git.bb')
-rw-r--r--recipes/shr/libphone-ui_git.bb19
1 files changed, 14 insertions, 5 deletions
diff --git a/recipes/shr/libphone-ui_git.bb b/recipes/shr/libphone-ui_git.bb
index 1bd11f5560..e73aa1eab2 100644
--- a/recipes/shr/libphone-ui_git.bb
+++ b/recipes/shr/libphone-ui_git.bb
@@ -2,15 +2,14 @@ DESCRIPTION = "A generic framework for phone ui"
HOMEPAGE = "http://shr-project.org/"
LICENSE = "GPL"
SECTION = "libs"
-SRCREV = "304538f6296b1da8390783d9c2a2f83435599e70"
+SRCREV = "5567443a48599c22c362fb28924701f81627c8dc"
PV = "0.0.1+gitr${SRCPV}"
-PR = "r2"
+PR = "r3"
DEPENDS="glib-2.0 libshr-glib libfso-glib libfsoframework libphone-utils alsa-lib"
SRC_URI = " \
git://git.shr-project.org/repo/libphone-ui.git;protocol=http;branch=master \
- file://libphoneui.conf \
"
S = "${WORKDIR}/git"
@@ -18,8 +17,18 @@ S = "${WORKDIR}/git"
inherit autotools pkgconfig
do_install_append() {
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/libphoneui.conf ${D}${sysconfdir}/libphoneui.conf
+ libphone_ui_install_machine_specific_configs
+}
+
+libphone_ui_install_machine_specific_configs() {
+ # Check for machine specific conf.
+ CONF_PATH="${S}/conf"
+ CONF_PATH_MACHINE="${CONF_PATH}"
+ if [ -d "${CONF_PATH}/${MACHINE}" ] ; then
+ CONF_PATH_MACHINE="${CONF_PATH}/${MACHINE}"
+ fi
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${CONF_PATH_MACHINE}/libphoneui.conf ${D}${sysconfdir}/libphoneui.conf
}
PACKAGES =+ "${PN}-config"