aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/shr/phoneui-shr-theme-neo_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/shr/phoneui-shr-theme-neo_git.bb')
-rw-r--r--recipes/shr/phoneui-shr-theme-neo_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/shr/phoneui-shr-theme-neo_git.bb b/recipes/shr/phoneui-shr-theme-neo_git.bb
new file mode 100644
index 0000000000..dd2f073f72
--- /dev/null
+++ b/recipes/shr/phoneui-shr-theme-neo_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "nEo phoneui-shr theme - a very fast, high contrast phoneui-shr theme"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+SECTION = "e/utils"
+LICENSE = "unknown"
+DEPENDS = "edje-native"
+RDEPENDS = "libphone-ui-shr"
+RSUGGESTS = "e-wm-theme-illume-neo gtk-theme-neo icon-theme-neo elementary-theme-neo"
+SRCREV = "768e6fd9d75bbe48dccd86eba1981d59e14ec9b9"
+PV = "0.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/phoneui-shr/${PN}"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/edje_cc -id ${S}/. -fd ${S}/. ${S}/neo.edc -o ${S}/neo.edj
+}
+do_install() {
+ install -d ${D}${datadir}/libphone-ui-shr/
+ install -m 0644 ${S}/neo.edj ${D}${datadir}/libphone-ui-shr/
+ install -m 0644 ${S}/config ${D}${datadir}/libphone-ui-shr/
+}
+
+FILES_${PN} = "${datadir}/libphone-ui-shr/"
+CONFFILES_${PN} = "${datadir}/libphone-ui-shr/config"