aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/sip/sip3-native_4.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/sip/sip3-native_4.0.1.bb')
-rw-r--r--recipes/sip/sip3-native_4.0.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/recipes/sip/sip3-native_4.0.1.bb b/recipes/sip/sip3-native_4.0.1.bb
new file mode 100644
index 0000000000..e833a31871
--- /dev/null
+++ b/recipes/sip/sip3-native_4.0.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "SIP - A Python Wrapper Generator"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.vanille.de/mirror/sip-${PV}.tar.gz"
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qmake native
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${STAGING_BINDIR} CONFIG=console"
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+