summaryrefslogtreecommitdiffstats
path: root/recipes/slugimage/slugimage.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/slugimage/slugimage.bb')
-rw-r--r--recipes/slugimage/slugimage.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/slugimage/slugimage.bb b/recipes/slugimage/slugimage.bb
new file mode 100644
index 0000000000..67367d5192
--- /dev/null
+++ b/recipes/slugimage/slugimage.bb
@@ -0,0 +1,24 @@
+# slugimage - normally built native, a perl script
+SECTION = "console/utils"
+LICENSE = "BSD"
+DESCRIPTION = "Slugimage is a small app to disassemble and reassemble \
+flash images for the Linksys NSLU2 device. It also has jffs2 support"
+PR = "r12"
+
+RDEPENDS = "perl"
+
+SLUGIMAGE_SVN_REV ?= "104"
+SLUGIMAGE_SVN_REPO ?= "http://svn.nslu2-linux.org/svnroot/slugimage/trunk"
+
+addtask svnfetch before do_configure after do_patch
+
+do_svnfetch() {
+ svn co ${SLUGIMAGE_SVN_REPO} --revision ${SLUGIMAGE_SVN_REV} ${WORKDIR}
+}
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 slugimage ${D}${bindir}/
+}