aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/snmp++
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/snmp++')
-rw-r--r--recipes/snmp++/snmp++_3.2.10.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/snmp++/snmp++_3.2.10.bb b/recipes/snmp++/snmp++_3.2.10.bb
new file mode 100644
index 0000000000..43af916aec
--- /dev/null
+++ b/recipes/snmp++/snmp++_3.2.10.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "A C++ SNMP library that supports SNMPv1, SNMPv2c and SNMPv3"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libdes libtomcrypt"
+LICENSE = "snmp++"
+SRC_URI = "http://www.agentpp.com/snmp++v${PV}.tar.gz"
+S = "${WORKDIR}/snmp++/src"
+
+CFLAGS_append = " -I../include"
+
+do_compile() {
+ oe_runmake -f Makefile.linux LIBDESDIR=${STAGING_LIBDIR} LIBTOMCRYPTDIR=${STAGING_LIBDIR}
+}
+
+do_stage() {
+ oe_libinstall -a -C ../lib libsnmp++ ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/snmp++
+ install -m 0644 ../include/*.h ${STAGING_INCDIR}/snmp++
+}