aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/softfan/softfan_0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/softfan/softfan_0.10.bb')
-rw-r--r--recipes/softfan/softfan_0.10.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/softfan/softfan_0.10.bb b/recipes/softfan/softfan_0.10.bb
new file mode 100644
index 0000000000..b589d736bf
--- /dev/null
+++ b/recipes/softfan/softfan_0.10.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Fan controller for fans attached to parallel port"
+SECTION = "base"
+PRIORITY = "optional"
+LICENSE = "GPL"
+SRC_URI = "http://joshuawise.com/code/softfan/softfan-${PV}.tar.gz"
+S = "${WORKDIR}/softfan-${PV}"
+
+FILES_${PN} = "/sbin/softfan"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o softfan softfan.c
+}
+
+do_install() {
+ install -d ${D}${base_sbindir}
+ install -m 0755 softfan ${D}${base_sbindir}/softfan
+}